Degraded performance with Identity & Credit Report Provider
Incident Report for etika
Resolved
We have observed an unbroken period of stability and are therefore closing this incident
Posted Aug 12, 2022 - 08:51 BST
Investigating
Our third party identification & credit verification provider has confirmed that they are currently investigating reports of an elevated error rate.

During this window, there may be an increase in failures pulling Identity and Credit Reports. Applications can still be made, but may result in a delay in receiving a final decision on the application.

As always, we continue to monitor our metrics for this unit and will update this ticket as information becomes available.
Posted Aug 10, 2022 - 18:43 BST
This incident affected: Identity Verification Provider.