Elevated refusal rate for some issuers
Incident Report for etika
Resolved
This incident has been resolved.
Posted May 15, 2023 - 12:51 BST
Identified
Our monitoring has identified a marginally elevated refusal rate on some 3D Secure authorisations currently being made.

We continue to monitor this situation, which is confirmed as an upstream problem - and are awaiting information from our provider on resolution.
Posted May 15, 2023 - 11:37 BST
This incident affected: Card Payment Processing.