Elevated refusal rate for some issuers
Incident Report for etika
Resolved
This incident has now been resolved, we continue to monitor the platform for unexpected failures.
Posted Mar 06, 2023 - 17:55 GMT
Investigating
Our monitoring has identified an elevated refusal rate on some card transactions currently being made.

We continue to monitor this situation and are awaiting information from our
Posted Mar 06, 2023 - 17:05 GMT
This incident affected: Card Payment Processing.