Elevated refusal rate for some issuers
Incident Report for etika
Resolved
This incident has been resolved, impact to the etika platform was limited and we've observed a window of stable operation since the last update.
Posted May 04, 2023 - 17:00 BST
Monitoring
We have identified that this is unlikely to impact customers at this stage, and as a result are continuing to monitor outcomes.
Posted May 04, 2023 - 13:02 BST
Identified
Our monitoring has identified an elevated refusal rate on some card transactions currently being made.

We continue to monitor this situation and are awaiting information from our supplier
Posted May 04, 2023 - 12:23 BST
This incident affected: Card Payment Processing.