3D Secure - Increased failures for some issuers
Incident Report for etika
Resolved
This incident has been resolved.
Posted Jun 26, 2023 - 16:57 BST
Monitoring
We have observed a return to normal behaviour as of 14:10 BST. We continue to monitor 3DS approval rates for further issues.
Posted Jun 26, 2023 - 14:58 BST
Investigating
Our monitoring has identified an elevated failure rate on 3D Secure authorisations for some card issuers.

We continue to monitor this situation and are awaiting information from our authorisation partners.
Posted Jun 26, 2023 - 14:29 BST
This incident affected: Card Payment Processing.