Degraded performance with Credit Report Provider
Incident Report for etika
Resolved
This incident has been resolved.
Posted May 17, 2023 - 13:04 BST
Monitoring
Our upstream provider is still investigating this incident, but emergency work has currently mitigated the impact. We continue to monitor systems for performance.
Posted May 17, 2023 - 09:55 BST
Update
We continue to observe an increased error rate from our provider and are monitoring impact closely.

Updates will be provided as available
Posted May 17, 2023 - 07:11 BST
Investigating
Our third party verification provider has confirmed that they are currently investigating reports of an elevated error rate.

During this window, there may be an increase in failures pulling Credit Reports. Applications can still be made, but may result in a delay in receiving a final decision.

As always, we continue to monitor our metrics for this unit and will update this ticket as information becomes available.
Posted May 17, 2023 - 06:49 BST
This incident affected: Credit Report Provider.