Elevated refusal rate for some issuers
Incident Report for etika
Resolved
This incident has been resolved.
Posted Oct 06, 2022 - 12:10 BST
Monitoring
A fix has been implemented and we are continuing to monitor card transaction success rates.
Posted Oct 06, 2022 - 09:18 BST
Update
We are continuing to investigate this issue.
Posted Oct 06, 2022 - 09:10 BST
Investigating
Our monitoring has identified an elevated refusal rate on some card transactions currently being made.

We continue to monitor this situation and are awaiting information from our
Posted Oct 06, 2022 - 09:08 BST
This incident affected: Card Payment Processing.