[Visa] Elevated Error Rate
Incident Report for etika
Resolved
Our card payment provider has advised Visa transactions have returned to normal across their network. This incident will now be closed, and any further impact will be noted in a new incident.
Posted Sep 22, 2022 - 18:33 BST
Investigating
Our monitoring has identified an elevated error rate for card transactions processed through Visa.

We continue to monitor this situation and are awaiting information from our payment service provider.
Posted Sep 22, 2022 - 17:12 BST
This incident affected: Application Journey and Card Payment Processing.