Elevated Refusal Rate
Incident Report for etika
Resolved
Our payment service provider have confirmed the upstream issue affecting 3DS authorization is now resolved.
Posted Oct 29, 2022 - 22:19 BST
Investigating
We are aware of an elevation in refusals against cards issued by several institutions on the payments network.

At present, impact appears to be relatively low but we continue to monitor the platform closely.
Posted Oct 29, 2022 - 21:12 BST
This incident affected: Application Journey and Card Payment Processing.