Elevated refusal rate for some issuers
Incident Report for etika
Resolved
This incident is now resolved - authorisation levels have returned to normal.
Posted Mar 16, 2023 - 21:22 GMT
Monitoring
Our provider has implemented a fix, and we have corroborated a decrease in refusals since 20:18. We will monitor this incident for a period of stability before closing.
Posted Mar 16, 2023 - 20:27 GMT
Investigating
Our monitoring has identified an elevated refusal rate on some card transactions currently being made, and our acquirer has confirmed they are aware of the issue.

We continue to monitor this situation and are awaiting information from our provider.
Posted Mar 16, 2023 - 20:20 GMT
This incident affected: Card Payment Processing.