[MasterCard] Elevated Refusal Rate
Incident Report for etika
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 15:48 GMT
Investigating
We are aware of an elevation in refusals against cards issued by several institutions on the MasterCard network.

At present, impact appears to be relatively low but we continue to monitor the platform closely.
Posted Jan 17, 2023 - 14:46 GMT
This incident affected: Application Journey and Card Payment Processing.