Degraded performance with Report Provider
Incident Report for etika
Resolved
This incident is now resolved. We continue to monitor metrics.
Posted Jun 27, 2023 - 21:10 BST
Investigating
Our third party data verification provider has confirmed that they are currently investigating reports of an elevated error rate.

During this window, there may be an increase in failures pulling Reports. Applications can still be made, but may result in a delay in receiving a final decision on the application.

As always, we continue to monitor our metrics for this unit and will update this ticket as information becomes available.
Posted Jun 27, 2023 - 19:52 BST
This incident affected: Credit Report Provider and Identity Verification Provider.