Degraded performance with External Report Provider
Incident Report for etika
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 15:48 BST
Investigating
Our third party verification provider has confirmed that they are currently investigating reports of an elevated error rate.

During this window, there may be an increase in failures pulling Identity & Credit Reports. Applications can still be made, but may result in a delay in receiving a final decision on the application.

As always, we continue to monitor our metrics for this unit and will update this ticket as information becomes available.
Posted Jul 20, 2022 - 12:47 BST
This incident affected: Identity Verification Provider.