[MasterCard] Elevated Error Rate
Incident Report for etika
Resolved
This incident has now been resolved by MasterCard, but we continue to monitor the platform.
Posted Jun 12, 2023 - 19:30 BST
Investigating
Our monitoring has identified an elevated error rate for card transactions processed through MasterCard.

We continue to monitor this situation and are awaiting information from our payment service provider.
Posted Jun 12, 2023 - 13:11 BST
This incident affected: Application Journey and Card Payment Processing.